(mt) Media Temple Chat/Phone Support - High Wait Times
Incident Report for (mt) Media Temple
Update
We are continuing to monitor for any further issues.
Posted Dec 16, 2022 - 13:50 PST
Monitoring
We are currently experiencing high call and chat volume resulting in extended wait times. We apologize for the delay and look forward to assisting you as soon as possible.

Please Note: At this time, GoDaddy customer support cannot assist Media Temple customers. We apologize for any inconvenience.
Posted Dec 16, 2022 - 13:15 PST
This incident affects: Support.